Notice of Service Interruption - Earth Networks (Product)

Incident Report for Earth Networks

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jul 28, 2026 - 19:40 EDT

Monitoring

Our network is operational at this time; however, we have enacted enhanced monitoring and will provide updates as needed.

Thank you,
Earth Networks Support Team
support@earthnetworks.com
Posted Jul 28, 2026 - 09:26 EDT

Update

We are continuing to investigate this issue.
Posted Jul 28, 2026 - 09:07 EDT

Update

We are continuing to investigate this issue.
Posted Jul 28, 2026 - 09:07 EDT

Investigating

Our network is operational at this time; however, we have enacted enhanced monitoring and will provide updates as needed.

Thank you,
Earth Networks Support Team
support@earthnetworks.com
Posted Jul 27, 2026 - 16:35 EDT
This incident affected: Sferic Maps (Current Observations Layers), Sferic Alerting (Weather Obs Alerts), and Sferic Data Stream, Online Weather Center.